Testez Online Php Obfuscator !

J’ai ressorti de mes tiroirs l’analyse d’un malware php qui était obfusquer pour passer à travers les antivirus, mais comme il a été utilisé massivement la signature d’obfuscation est maintenant grillée.

Cela a été l’occasion pour moi d’écrire un outil pour obfusquer du code php d’une manière qui ne soit pas (encore) détectée, et en même temps de résoudre la signature statique que j’ai utilisée. C’est pourquoi j’ai également développer 3 autres versions dont 2 polymorphes utilisable en CLI ou directement en http.

Online Php Obfuscator

Augmenter la taille d’un disque VirtualBox sur Osx

Pour éviter de prendre trop de place avec mes VM sur le disque de mon mac, je choisi souvent une petite taille pour les VDI et des fois … il en manque !

Malheureusement sur Mac il n’y a pas de menu expand et il faut donc passer par le terminal.

Les pré-requis :

  • Connaitre la taille du disque VirtualBox
  • Savoir ou le fichier VDI se situe
  • Connaitre la différence entre supérieur et inférieur

Ouvrir le terminal pour :

cd /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/MacOS
ls -hl /Users/cyklo/VirtualBox\ VMs/ghest/ghest.vdi
-rw-------  1 cyklo  staff  9.0G  6 Jun 21:28 /Users/cyklo/VirtualBox\ VMs/ghest/ghest.vdi

J’ai donc un disque de 9G que je vais augmenter à 20G.

VBoxManage modifyhd /Users/cyklo/VirtualBox\ VMs/ghest/ghest.vdi  --resize 20000
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

Et voilà il ne reste plus qu’à prendre une iso de Gparted pour faire le resize dans l’os client.

OpenSSL … un trou de plus dans le gruyère !

Décidément Hearthbleed n’était pas le seul problème dans OpenSSL, une nouvelle vulnérabilité vient d’être découverte, une possibilité d’attaque de l’homme du milieu (MITM) et pas seulement sur la version 1.* mais également sur la branche 0.9.8 !

Elle a été publié le 1 mai 2014 et vient d’être intégrée aux CVE (CVE-2014-0224) le descriptif complet est ici.

Pour y remédier, vous pouvez vous reporter ci dessous pour voir si vous êtes dans ce cas.
OpenSSL 0.9.8 SSL/TLS users (client and/or server) should upgrade to 0.9.8za.
OpenSSL 1.0.0 SSL/TLS users (client and/or server) should upgrade to 1.0.0m.
OpenSSL 1.0.1 SSL/TLS users (client and/or server) should upgrade to 1.0.1h.

Même si l’attaque est délicate puisque elle doit combiner un client et un serveur vulnérable, il semble que seul le navigateur Chrome sur Android est touché puisqu’il embarque OpenSSL. Les autres navigateurs (Firefox, Firefox mobile, Safari, Safari mobile) ne sont pas exposés.

Surveillez ça de près et éviter de surfer avec votre Chrome sur Android.

Mon coeur saigne .. et ca fait mal ! Vulnérabilité sur OpenSSL

La nouvelle est plutôt mauvaise, une vulnérabilité a été découverte dans le paquet openssl, et pas une petite ! Le bug nommé Heartbleed permet à quiconque de lire la mémoire d’un serveur à distance, autant dire qu’une mise à jour est rapidement à faire.

Pour vérifier si vous êtes concernés :

openssl version
openssl version
OpenSSL 1.0.1g 14 Feb 2013

Voila une petite liste des versions atteintes par le bug :

  • OpenSSL 1.0.1 through 1.0.1f (inclusive) are vulnerable
  • OpenSSL 1.0.1g is NOT vulnerable
  • OpenSSL 1.0.0 branch is NOT vulnerable
  • OpenSSL 0.9.8 branch is NOT vulnerable

Mettez au plus vite votre systeme à jour !

apt-get update
apt-get upgrade

ou

yum update
yum upgrade

En pensant bien à redémarrer tous les services utilisant openssl !

Toutes les infos sur un site dédié à cette sacrée vulnérabilité. (Source Heartbleed)